Commit 0b692030 authored by Marcin Sobczyk's avatar Marcin Sobczyk
Browse files

Warn when using cli_wallet with different chain-id

then chain-id of connected node
parent 4ff7eb5c
......@@ -886,6 +886,9 @@ public:
if( broadcast ) {
try {
auto v = _remote_wallet_bridge_api->get_version({}, LOCK);
FC_ASSERT( _hive_chain_id == v.chain_id, "chain id on wallet does not mach chain id on node" );
if( blocking )
{
auto result = _remote_wallet_bridge_api->broadcast_transaction_synchronous( vector<variant>{{variant(tx)}}, LOCK );
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment